Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Profile: hhhjaam
Name: hhhjaam Offline
Joined: Saturday, December 24, 2016(UTC)
Last Visit: Saturday, December 24, 2016 7:05:53 PM(UTC)
Number of Posts: 5
[0.00% of all post / 0.00 posts per day]
Thanks Given: 1 (View Thanks)
Thanks Received: 0
Thanked Posts: 0
Community Reputation Received:
View All Posts by User
Topic: Sapphire r9 270 black screen during driver installation   Go to last post
Posted: Saturday, December 24, 2016 7:05:52 PM(UTC)
Originally Posted by: Blackhawk8100 Go to Quoted Post
You should be fine. 600w is more than enough to run most GPUs of that spec range.

THANKS ALOT MATE for your time and your expert help

Take care mate

Topic: Sapphire r9 270 black screen during driver installation   Go to last post
Posted: Saturday, December 24, 2016 6:06:06 PM(UTC)
Originally Posted by: Blackhawk8100 Go to Quoted Post
It seems that way :/

I think so too bro

One more thing mate if i buy 1060 or 1070 nvidia or 480 amd do i need to change my psu

my psu is thermaltake litepower 600w and my board is msi z68 45 g3?

Topic: Sapphire r9 270 black screen during driver installation   Go to last post
Posted: Saturday, December 24, 2016 3:41:47 PM(UTC)
Originally Posted by: Blackhawk8100 Go to Quoted Post
I tracked this down, maybe it'll help?

https://community.amd.com/message/2743721

Thanks alot mate for your valuable information and time

3. Black screen/hang during the installation of the AMD graphics driver

My issue is third in the link you've shared

so it seems i may have to buy a new graphics card?

Topic: Sapphire r9 270 black screen during driver installation   Go to last post
Posted: Saturday, December 24, 2016 1:30:43 PM(UTC)
Originally Posted by: Blackhawk8100 Go to Quoted Post
Does the screen show up after finishing installing the drivers? Flickering when installing drivers for a GPU is normal I think...

It doesnt show up after it flicker computer hangs untill i remove graphics card and move display to integrated graphics on board then the display works fine.

But if i uninstall drivers in safemode and attach card again the display works fine untill i install drivers again the display goes black again and pc hangs.

p.s the drivers never finishes full installation computer freeze during screen flickering and screen goes black.

Topic: Sapphire r9 270 black screen during driver installation   Go to last post
Posted: Saturday, December 24, 2016 9:57:37 AM(UTC)
I wanted to know if its graphics card issue or motherboard or psu that during amd driver installation my pc screen flicker then computer freeze and everything else is working fine including PSU Processor Rams HDD etcetra what i want to know is weather its my graphics card thats faulty or something else causing that issue.

Motherboard is detecting Amd graphics card.

I tried installing older versions of drivers too but with issue persist

Any thoughts guys ? Just wanna make sure before i buy new GPU that this one is dead