Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
Offline hhhjaam  
#1 Posted : Saturday, December 24, 2016 4:57:37 AM(UTC)
hhhjaam


Rank: Newbie

Reputation:

Groups: Registered
Joined: 12/24/2016(UTC)
Posts: 5

Thanks: 1 times
I wanted to know if its graphics card issue or motherboard or psu that during amd driver installation my pc screen flicker then computer freeze and everything else is working fine including PSU Processor Rams HDD etcetra what i want to know is weather its my graphics card thats faulty or something else causing that issue.

Motherboard is detecting Amd graphics card.

I tried installing older versions of drivers too but with issue persist

Any thoughts guys ? Just wanna make sure before i buy new GPU that this one is dead

Offline Blackhawk8100  
#2 Posted : Saturday, December 24, 2016 7:14:06 AM(UTC)
Blackhawk8100


Rank: Administration

Reputation:

Groups: Administrators, Moderator, Registered
Joined: 5/7/2014(UTC)
Posts: 1,941
Man
United States
Location: A Cold Place

Thanks: 6 times
Was thanked: 46 time(s) in 42 post(s)
Does the screen show up after finishing installing the drivers? Flickering when installing drivers for a GPU is normal I think...
Offline hhhjaam  
#3 Posted : Saturday, December 24, 2016 8:30:43 AM(UTC)
hhhjaam


Rank: Newbie

Reputation:

Groups: Registered
Joined: 12/24/2016(UTC)
Posts: 5

Thanks: 1 times
Originally Posted by: Blackhawk8100 Go to Quoted Post
Does the screen show up after finishing installing the drivers? Flickering when installing drivers for a GPU is normal I think...

It doesnt show up after it flicker computer hangs untill i remove graphics card and move display to integrated graphics on board then the display works fine.

But if i uninstall drivers in safemode and attach card again the display works fine untill i install drivers again the display goes black again and pc hangs.

p.s the drivers never finishes full installation computer freeze during screen flickering and screen goes black.

Offline Blackhawk8100  
#4 Posted : Saturday, December 24, 2016 10:25:03 AM(UTC)
Blackhawk8100


Rank: Administration

Reputation:

Groups: Administrators, Moderator, Registered
Joined: 5/7/2014(UTC)
Posts: 1,941
Man
United States
Location: A Cold Place

Thanks: 6 times
Was thanked: 46 time(s) in 42 post(s)
I tracked this down, maybe it'll help?

https://community.amd.com/message/2743721

Offline hhhjaam  
#5 Posted : Saturday, December 24, 2016 10:41:47 AM(UTC)
hhhjaam


Rank: Newbie

Reputation:

Groups: Registered
Joined: 12/24/2016(UTC)
Posts: 5

Thanks: 1 times
Originally Posted by: Blackhawk8100 Go to Quoted Post
I tracked this down, maybe it'll help?

https://community.amd.com/message/2743721

Thanks alot mate for your valuable information and time

3. Black screen/hang during the installation of the AMD graphics driver

My issue is third in the link you've shared

so it seems i may have to buy a new graphics card?

Offline Blackhawk8100  
#6 Posted : Saturday, December 24, 2016 11:57:31 AM(UTC)
Blackhawk8100


Rank: Administration

Reputation:

Groups: Administrators, Moderator, Registered
Joined: 5/7/2014(UTC)
Posts: 1,941
Man
United States
Location: A Cold Place

Thanks: 6 times
Was thanked: 46 time(s) in 42 post(s)
It seems that way :/
Offline hhhjaam  
#7 Posted : Saturday, December 24, 2016 1:06:06 PM(UTC)
hhhjaam


Rank: Newbie

Reputation:

Groups: Registered
Joined: 12/24/2016(UTC)
Posts: 5

Thanks: 1 times
Originally Posted by: Blackhawk8100 Go to Quoted Post
It seems that way :/

I think so too bro

One more thing mate if i buy 1060 or 1070 nvidia or 480 amd do i need to change my psu

my psu is thermaltake litepower 600w and my board is msi z68 45 g3?

Offline Blackhawk8100  
#8 Posted : Saturday, December 24, 2016 1:44:39 PM(UTC)
Blackhawk8100


Rank: Administration

Reputation:

Groups: Administrators, Moderator, Registered
Joined: 5/7/2014(UTC)
Posts: 1,941
Man
United States
Location: A Cold Place

Thanks: 6 times
Was thanked: 46 time(s) in 42 post(s)
You should be fine. 600w is more than enough to run most GPUs of that spec range.
thanks 1 user thanked Blackhawk8100 for this useful post.
hhhjaam on 12/24/2016(UTC)
Offline hhhjaam  
#9 Posted : Saturday, December 24, 2016 2:05:52 PM(UTC)
hhhjaam


Rank: Newbie

Reputation:

Groups: Registered
Joined: 12/24/2016(UTC)
Posts: 5

Thanks: 1 times
Originally Posted by: Blackhawk8100 Go to Quoted Post
You should be fine. 600w is more than enough to run most GPUs of that spec range.

THANKS ALOT MATE for your time and your expert help

Take care mate

Offline Blackhawk8100  
#10 Posted : Saturday, December 24, 2016 2:38:59 PM(UTC)
Blackhawk8100


Rank: Administration

Reputation:

Groups: Administrators, Moderator, Registered
Joined: 5/7/2014(UTC)
Posts: 1,941
Man
United States
Location: A Cold Place

Thanks: 6 times
Was thanked: 46 time(s) in 42 post(s)
No problem, Happy Holidays!
Users browsing this topic



Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.