I have an ASUS P4C800 Deluxe motherboard and an ATI Radeon 9800 Pro 256mb. However, the problem is I cannot enable 8x agp with any of the Catalyst drivers from 3.8 and up. I am therefore stuck with using the 3.7 drivers. The only options it gives me are Off, 2x, and 4x. I can drag it to 8x, but after I restart the PC, it goes back to either Off, 2x, or 4x. I tried almost everything. I updated my BIOS, firmware, etc. Any help WOULD be apreciated.

PS: I am hesitant to try the 4.1 Catalysts because it probably will be the same result. The "Fixed in this Driver" note of the new drivers don't mention anything on this matter either.
So 8X support is enabled in your BIOS?

Release notes sometimes don't contain a lot of things fixed - that and it might not have been a known bug in the driver, but just a small conflict with your system. I would uninstall your current drivers and install the new ones before trying anything else.

Update your Board's AGP Driver.. and also remove the drivers of the video card.. reboot, than install the ATI Catalyst 3.10 ..

Good Luck..

and as Telexen suggested check out in the BIOS.
A lot of it has to do with future proofing lol So it'd be up to you lol