Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
Offline James@PCPosh  
#1 Posted : Tuesday, April 26, 2016 12:11:40 AM(UTC)
James@PCPosh


Rank: Member

Reputation:

Groups: Registered
Joined: 3/30/2016(UTC)
Posts: 80
Man
United States

Thanks: 7 times
Was thanked: 3 time(s) in 3 post(s)
By default, when I comment on a thread here I'm automatically subscribed to it and receive notifications of activity via email (This isn't a complaint and, yes, I am aware I can toggle it off)... But there is a rather notable issue.

The links it provides me to the latest comment are broken; the URL sent over is has a percent sign instead of a pound sign, and because of this, the link doesn't take me any deeper than the forum index...

For example:

http://hothardware.com/f...5-Cool-Case%23post613585

VS

What it should be: http://hothardware.com/f...5-Cool-Case#23post613585

Not sure how big of a pain in the neck that would be to fix. Odds are an update from YAF would resolve the issue, unless the staff here wants to get elbow deep in the emailer code and try to patch this themselves.

Offline Blackhawk8100  
#2 Posted : Tuesday, April 26, 2016 7:58:53 AM(UTC)
Blackhawk8100


Rank: Administration

Reputation:

Groups: Administrators, Moderator, Registered
Joined: 5/7/2014(UTC)
Posts: 1,941
Man
United States
Location: A Cold Place

Thanks: 6 times
Was thanked: 46 time(s) in 42 post(s)
It is being looked at James, thanks for the report!
Offline JimmyB  
#3 Posted : Tuesday, April 26, 2016 11:11:40 AM(UTC)
JimmyB


Rank: Member

Reputation:

Groups: Administrators, Registered
Joined: 2/17/2006(UTC)
Posts: 25
Location: United States, Pennsylvania

I haven't seen this issue. Will see if I'm affected.
Offline Dave_HH  
#4 Posted : Tuesday, April 26, 2016 11:19:59 AM(UTC)
Dave_HH


Rank: Advanced Member

Reputation:

Groups: Administrators, Editors, Moderator, Registered
Joined: 7/12/2004(UTC)
Posts: 3,692
Man
Location: United States, Massachusetts

Thanks: 1 times
Was thanked: 12 time(s) in 11 post(s)
OK fellas, we checked this out and unfortunately it looks like an issue with James' email client. We're seeing messages coming through with the link properly formed and working.

It must be the email client that doesn't support the # symbol and turns it into %23 which is essentially unused hex code. The crazy thing is the # symbol has been represented for ages in URLs and in HTML to code bookmarks for positioning of a cursor on the page for a reader to come back to a place where they left off.

So, in this case, the #23post613585 part of that URL indicates the post number 23 in that thread, brings you right to it.

Hope this helps. Time for a new email client maybe? I'm getting links in Outlook and Gmail no problem.

Offline James@PCPosh  
#5 Posted : Tuesday, April 26, 2016 2:42:16 PM(UTC)
James@PCPosh


Rank: Member

Reputation:

Groups: Registered
Joined: 3/30/2016(UTC)
Posts: 80
Man
United States

Thanks: 7 times
Was thanked: 3 time(s) in 3 post(s)
Originally Posted by: Dave_HH Go to Quoted Post
OK fellas, we checked this out and unfortunately it looks like an issue with James' email client.

Can verify upon closer inspection the mail client is definitely receiving the proper links, but clicking on them swaps the # for a %. I'll be swapping out email clients, and I apologize for the false report.

Offline Blackhawk8100  
#6 Posted : Tuesday, April 26, 2016 3:09:15 PM(UTC)
Blackhawk8100


Rank: Administration

Reputation:

Groups: Administrators, Moderator, Registered
Joined: 5/7/2014(UTC)
Posts: 1,941
Man
United States
Location: A Cold Place

Thanks: 6 times
Was thanked: 46 time(s) in 42 post(s)
Originally Posted by: James@PCPosh Go to Quoted Post
Can verify upon closer inspection the mail client is definitely receiving the proper links, but clicking on them swaps the # for a %. I'll be swapping out email clients, and I apologize for the false report.

No worries, its always good to check! grin

Users browsing this topic



Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.