I just installed a gigabyte z87-d3hp (rev 1.0) mobo with intel g3258 cpu and Vulcan ddr3 1600 ram. (with Silverstone 750w sst-st75zf PSU)

when I power it on I get lots (>20) short beeps then it powers itself off.

the mobo has UEFI dual bios printed on it - the manual says its AMI EFI bios.

nowhere can I find an explanation of >20 short beeps except for AWARD bios which says its a power issue. BUT I DONT HAVE AWARD BIOS...???!?!?! (or do I?)

could anybody help?

ok - maybe it is a power issue. I just tried to power it up again and the socket's breaker tripped. Time to try a backup PSU.
Super Dave
Hope the PSU didn't damage the motherboard.
it worked fine after using an older PSU.

no problems as such, except now windows wont boot (BSOD after the initial windows logo appears). I've not done a fresh windows7 install after the update, but I was thinking a repair was all it would take. But the repair fails ("windows can not repair this installation") and I can only do a fresh intsall.

Should I go with the fresh-install or is there a workaround to repair it? (Is this UEFI thing the problem?). I already found a fix for the MBR vs GPT UEFI windows install problem, but wondering if its blocking the repair now somehow...?

Der Meister
With that big of a hardware change your going to need a clean install. You might be able to save some of the data off the drive when your installing windows again you can create a new partition for the new install. Then boot the new windows you can get some of your data off but game flies and saves will not be save able. Then once done you can delete the old windows partition and your drive is back to normal.
Wierd issue. Case closed I guess.