sgtparks
  •  sgtparks
  • 50.25% (Neutral)
  • Member Topic Starter
2008-12-24T01:22:46Z

 I recently decided to try upgrade my Gigabyte GA-P35-DS3L based system from an PNY Nvidea 8500 Vid card to a BFG Nvidea 260 based card. I realized this would require a beefier PSU than the 450 watt I had in the system so I purchased and installed a new Thermaltake TR2 RX-850 Modular Power supply. After connecting the MB to the PSU (including the 4 pin connector next to the CPU socket) and connecting the dedicated PCIe power cables to the vid card I tried to start the system up. The fan on the vid card never even spun up. The fans on the Mobo were spinning away so I was a bit confused. I had a PS tester at hand so I hooked it across the 24 pin connector and discovered that the -5 volt indicator was not lighting up. I repeated the test with the old PSU and that indicator did light. Thinking it was an issue with the Thermaltake unit I returned to the point of purchase to swap it for another. I took the tester with me to confirm that the next PSU was working properly. It failed to light that same -5 volt indicator as well. The Geek squad guys said that was normal and that the power supply was likely not compatible with that model Mobo. Is that possible?  I poked arouns a bit on the Gigabyte sight and the thermaltake sites but never did find any compatibility charts. I know this isn't the latest and Greatest Mobo but its rated up to quad core and even extreme duo processors so I made an assumption that this combo would work. So much for assumptions. Now I am going to make this a project box but want to get a Mobo and CPU combo that will work with all the other parts I have on hand.  Any thoughts?

bob_on_the_cob
2008-12-24T02:07:33Z

Geek Squad is not the most knowledgeable bunch. There are some very smart people that work for them, but that is the minority. If both the mobo and PSU are 24 pin and 4 pin then they should work together. If not look elsewere for a PSU. That is still a capable motherboard.

 

Der Meister
2008-12-24T03:28:54Z

I would tend to disagree with geek squad on this one. I would try a diffrent PSU brand, and if you can a non modular one might do the trick as well.

Unlike that geeksquad said it is not a normal thing for a PSU/mobo to be incompatiable.

ice91785
2008-12-24T11:19:41Z

bob_on_the_cob wrote:

Geek Squad is not the most knowledgeable bunch

 

Easy now....one of them in amongst you currently [8-|]

However even though I work for the Geek Squad I would tend to agree that they dropped the ball on this one...there is really no such thing as an "incompatible" PSU as far as your mobo is concerned. If you are running to BBY again try the Antec that we stock -- you should (I have in customer's computers) have better luck with it

Der Meister
2008-12-24T19:02:52Z

Ice you are the exception to that genrarality.

bob_on_the_cob
2008-12-24T22:19:43Z

ice91785 wrote:

[quote user="bob_on_the_cob"]Geek Squad is not the most knowledgeable bunch

 

Easy now....one of them in amongst you currently Geeked

 

You forgot part of that quote[;)]

[quote user="bob_on_the_cob"]There are some very smart people that work for them,

sgtparks
  •  sgtparks
  • 50.25% (Neutral)
  • Member Topic Starter
2008-12-24T22:40:28Z

 Here are the facts from Thermaltake and I quote!

Hello Peter,
Thank you for contacting Thermaltake Customer Service.

The -5v rail is no longer used for CPUs or motherboards. It has not been used since the first P4 and socket A. Only older systems will require the -5v. Newer motherboards and CPUS are now using ATX series 2.0 or higher standards. With this, they no longer require a -5v to operate. Therefore, new power supplies are not manufactured with a -5v rail.

I guess my next question will be directed at BFG and the vid card.