Pam Heinze

I have this Gateway laptop with a Pentium M processor.  I always wanted to dual boot Windows XP Pro and Ubuntu but could never get the partition resized with either Ubuntu installation partitioner or qparted.  So I got this brilliant idea to buy another hard drive for this laptop.  I successfully installed Ubuntu on a new Seagate 80G hard drive and everything worked, wireless, etc, and thought, hooray, now I kind of have a "dual boot".

 The next time I swapped in the Ubuntu drive, Intel Boot agent could not see this drive.  I thought, Oh, shoot, this drive is broken now.  But was it?  I bought one of those adapter thingys and put the drive into a desktop and was able to see it there and intsall Fedora on it and played with it a little and went on to other things.

 Last week, this laptop had a bad crash and it couldn't see the Windows XP drive.  I could run a Linux live cd on it, but when I'd try to boot the drive, there was a distressing clicking noise, which suggested to me the drive was dead.  I was very sad.  I turned the computer off and turned it upside down.  Why did she turn it upside down?  Maybe whatever made the drive click would get better, she thought desperately.

 The next day, I turned it on and lo, there was no clicking and Windows XP came right up.  But I decided to back up my files and settings and maybe see about installing Windows onto that new laptop drive, which is bigger and this laptop could see that one time but never again.  

 And no matter what I do, it still refuses to see it.  I tried putting the Windows XP cd in and maybe the partitioner there could clear out all that Fedora crap but XP said it couldn't see a hard drive and the bios can't see a hard drive and when I put the old drive back in, that hard drive is there.

 Now for those of you thinking "jumpers",  there are no jumpers on these drives.  The pins are bare, the original drive is operating in "master" mode and appears in the bios as IDE 0 master.  I can fiddle with IDE settings that make the dvd drive disappear or just the dvd drive appear, but I can't see the new drive with the default IDE controller setting, which is "both" where the hard drive is IDE 0 master and the dvd is IDE 1 master.

 I am flummoxed that the new drive, a Seagate 80 gig, was visible long enough to successfully install Ubuntu, never to be seen again when it was reinserted.  I swear, it seats completely, goes in just as far as the original Hitachi 60 Gig.  The black adapter thing used to come out with the Hitachi, and now stays inside the laptop.  Which is fine with me, the less I am messing with all those pins and bending them, the happier I am.

 So, anybody else swapped laptop hard drives and run up against the new drive's invisibility? This is a 4 year old Gateway laptop with a 450RGH mobo for which I have the last bios ever offered for it.  Thanks for reading this,


Pam Heinze

I think the problem here is some kind of seating issue.  If I leave the little plastic cover off and push on the drive with my thumb, I can make it appear with a reboot.  But if I try to install Windows or Ubuntu, and don't keep pushing on the drive, even though I didn't feel it move when I was pushing on it, neither Windows or Ubuntu can see it and it disappears from the BIOS.  I don't want to sit here with my thumb on the drive while I try to install an operating system on it, so I guess I can maybe eBay the drive, although I would worry any buyer might have this same issue.  So I guess I'll just use it with some desktop some time, since I have an adapter for that. 

So I guess the moral of the story is: don't be yanking drives in and out of a laptop.