Guest
marrero984
2007-01-20T00:29:27Z
i'm using an ASUS p5nsli mobo, and windows home edition off a dell installation disk. everything works, except that the usb ports do not run as 2.0. everytime i plug in a device that uses 2.0, it gives me the message that the device would run faster in a 2.0. i went to install 2.0 drivers from the cd that came with the mobo, however when i try that, i says that windows running service pack 2 should already have the drivers for usb 2.0. any ideas on how to make them run properly?
Sponsor
Sillysod
2007-01-26T05:14:50Z
Is there no option to install the USB2.0 drivers anyway?

http://www.softwarepatch.com/tips/usb2-driver.html

Read through that and see if it helps.
stuio
2007-01-27T19:18:29Z
i have that driver installed, my mate bought his usb 80gb external HD round plugged it in and my pc said i needed to use usb2 which would be quicker for transfers... transferring files onto it were so slow!
LennyV
2011-11-01T19:24:31Z

Hi. This thread is pretty old but wondered if anyone is still monitoring it. I have the same problem on my p5nsli board now. I run Windows 7 professional and it works very well except for a few glitches and they may not be a function of Windows 7 but rather the motherboard.  The USB ports that are connected to the pins at the bottom of the motherboard don't work (well). When I plug in a device, the device is recognized but then fairly quickly aborts or stops or aborts and the device turns off and on a few times. So there seems to be a problem with this set of pin connections. I removed the cables that were there (connected to the ports at the front of the desktop box) and installed the bracket that is mounted to the rear of the box and connected it to these pins. Same result. Does anyone have any ideas? is it a bios upgrade I need or maybe the hardware connectors are faulty?

The other problem I have now with Windows7 is my HP Laserjet 1300 doesn't work when connected to the p5nsli usb port.

AKwyn
  •  AKwyn
  • 71.2% (Friendly)
  • Advanced Member
2011-11-01T20:09:21Z

Hey, I doubt these guys have logged in for a long time; but for the most part, I'm here to help. Anyway...

1. What's your BIOS version? The last BIOS version released was 1801 so if your BIOS version is that then it isn't a BIOS problem.

2. It's likely a hardware problem with the pins. I don't know if you tried other ports before (may not be the pins) but I'm guessing that one of the pins may be bent or not sodered on correctly. I don't know how to soder pins myself but take a closer look at the pins, are they bent, does one of them look off... Take a picture if possible.

I'm sure that other people will be here to help you with your situation, don't worry; we're a vibrant community, we help out when we can.

omegadraco
2011-11-01T20:54:19Z

Do the ports directly on the motherboard work properly?

It could also be a problem with the computer cases USB ports.

Super Dave
2011-11-01T21:16:47Z

Welcome to HotHardware, Lenny. This IS an old thread so you may not get many replies. It's always better to start a new thread than to post a question on an old thread! If you haven't already done so I would suggest that you visit the HP website and download the latest Windows 7 driver for your Laserjet printer. Hopefully that will work for you. As for the USB motherboard connection you will need to look in the user's manual and verify that the board's USB pinout matches the wiring on the plug itself. The reason for doing this is because there is no standardization between motherboard manufacturers as to the pin assignments. HERE is an informative article about USB pinout.

realneil
2011-11-01T21:34:47Z

LennyV wrote:

The other problem I have now with Windows7 is my HP Laserjet 1300 doesn't work when connected to the p5nsli usb port.

Laserjet 1300 is not compatible with windows 7.  My LJ1012 has the same issue. It's perfect on an XP box, and it's perfect on my Ubuntu box as well.

LennyV
2011-11-01T23:04:56Z

Hi TaylorKarras... Thanks for the reply... I am not exactly sure what the BIOS version is... looked for it in the startup (pressed delete at startup) but it doesn't display the version number  there. Any ideas where I can find the version number?  Re the pins, I looked at them and they appear to be ok but it's hard to see them well, with the various hard drives, cables and cards I have installed being in the way. I'll take it apart again tomorrow and see if I can get a good picture... forgot to do that before I put it back together today.

LennyV
2011-11-01T23:25:55Z

Hi Super Dave... Seems I did get a couple of replies and if this doesn't work I will start a new thread.  I did visit the HP website and downloaded the latest Windows 7 driver... several times and different ones. Didn't help. Windows 7 does have a driver for the device and it installs successfully automatically.  Another reply already suggested that this printer is not compatible with Windows 7 and I suspect that is the case. It works very well with XP and also with MACs, but not Microsoft Windows 7. With Windows 7 I can usually print one page at a time, but if I print more than one, it eventually says 'printer error' and stops.  I checked Google many times and read what others say and it seems I am not the only one with the problem and nobody said they solved it yet.  Re the USB connection, I pulled out the 9 individual wires which were connected to the front usb ports, and replaced them with a single plug which fit over the 9 pins (standard connector on the supplied 2 port usb unit that can be installed in the rear of the case) and the result was the same. I will tomorrow reattach the 9 wires as per the user's manual for the motherboard and see if the front ones will work, but am not holding my breath since the one I installed today with the preconfigured connector gave the same results.

LennyV
2011-11-01T23:32:25Z

Yes the ports on the rear of the motherboard work very well. Also the one that is on the istar card reader installed just under the floppy drive works well. Just the ones that are attached by wires to the pins on the motherboard don't work. I installed a different device attached to these same pins that were connected to the 2 ports on the front, and got the same result. By the way, I just came back from Future Shop looking for a USB card to install internally and they don't carry them any more.  

LennyV
2011-11-01T23:40:03Z

Hey realneil... Thanks for the response... I kind of figured that is the case. I have tried everything, tried a bunch of drivers, even spent money adding a 64 MB Memory DIMM card expansion and achieved the same result. Don't know why HP or Microsoft wouldn't offer a solution. I hate to throw this printer out, as it is excellent and has worked very well to now. My other PC's (XP) and Macs work well with this printer.

realneil
2011-11-02T00:31:03Z

HP decided not to support that series of printer in Windows 7. It's really a shame because they're very robust and fast little printers when used with the correct OS. Mine works well with Apple's OS-X, and XP, and Ubuntu also.

You'll be able to install the driver for Vista,....but it will usually ~time-out~ after one or two pages, and crash the print spooler. Multiple requests to HP for help went unanswered. They've done the same with other printers in the past too.

Mine is used daily with a Ubuntu System, because I bought 12 toner cartridges for $25.00 from an office that couldn't use their two little Laser printers anymore. That was a long time ago and I still have 10 of those cartridges left. [:)]

LennyV
2011-11-02T00:54:24Z

Wow. I can't figure out why HP wouldn't support this printer series. It is a great printer. Guess I will keep it for my one page prints and also for my other computers. BTW I need a new toner cartridge for this printer. Can I buy one of your 12? Don't know where you live and what the shipping cost might be but maybe it's worth it to have one shipped to me. I live in Vancouver Canada.

realneil
2011-11-02T01:04:43Z

Not gonna sell them,... but I just bought toner for another laser-jet printer HERE. Good prices and fast shipping.