hhhjaam
  •  hhhjaam
  • 54.5% (Neutral)
  • Newbie Topic Starter
2016-12-24T09:57:37Z
I wanted to know if its graphics card issue or motherboard or psu that during amd driver installation my pc screen flicker then computer freeze and everything else is working fine including PSU Processor Rams HDD etcetra what i want to know is weather its my graphics card thats faulty or something else causing that issue.

Motherboard is detecting Amd graphics card.

I tried installing older versions of drivers too but with issue persist

Any thoughts guys ? Just wanna make sure before i buy new GPU that this one is dead

Blackhawk8100
2016-12-24T12:14:06Z
Does the screen show up after finishing installing the drivers? Flickering when installing drivers for a GPU is normal I think...
hhhjaam
  •  hhhjaam
  • 54.5% (Neutral)
  • Newbie Topic Starter
2016-12-24T13:30:43Z
Originally Posted by: Blackhawk8100 

Does the screen show up after finishing installing the drivers? Flickering when installing drivers for a GPU is normal I think...

It doesnt show up after it flicker computer hangs untill i remove graphics card and move display to integrated graphics on board then the display works fine.

But if i uninstall drivers in safemode and attach card again the display works fine untill i install drivers again the display goes black again and pc hangs.

p.s the drivers never finishes full installation computer freeze during screen flickering and screen goes black.

Blackhawk8100
2016-12-24T15:25:03Z
hhhjaam
  •  hhhjaam
  • 54.5% (Neutral)
  • Newbie Topic Starter
2016-12-24T15:41:47Z
Originally Posted by: Blackhawk8100 

I tracked this down, maybe it'll help?

https://community.amd.com/message/2743721 

Thanks alot mate for your valuable information and time

3. Black screen/hang during the installation of the AMD graphics driver

My issue is third in the link you've shared

so it seems i may have to buy a new graphics card?

Blackhawk8100
2016-12-24T16:57:31Z
It seems that way :/
hhhjaam
  •  hhhjaam
  • 54.5% (Neutral)
  • Newbie Topic Starter
2016-12-24T18:06:06Z
Originally Posted by: Blackhawk8100 

It seems that way :/

I think so too bro

One more thing mate if i buy 1060 or 1070 nvidia or 480 amd do i need to change my psu

my psu is thermaltake litepower 600w and my board is msi z68 45 g3?

Blackhawk8100
2016-12-24T18:44:39Z
You should be fine. 600w is more than enough to run most GPUs of that spec range.
hhhjaam
  •  hhhjaam
  • 54.5% (Neutral)
  • Newbie Topic Starter
2016-12-24T19:05:52Z
Originally Posted by: Blackhawk8100 

You should be fine. 600w is more than enough to run most GPUs of that spec range.

THANKS ALOT MATE for your time and your expert help

Take care mate

Blackhawk8100
2016-12-24T19:38:59Z
No problem, Happy Holidays!