•  AKwyn
  • 71.2% (Friendly)
  • Advanced Member Topic Starter

Okay, so my Hard Drive (Western Digital Green 500GB IDE) has been having problems lately and has been exhibiting these in particular.

When the computer turns on, the Hard Drive in general fails to initalize, (I tried to access this disk with the Windows 7 DVD and it said "The Device is not Ready")

This is rare but somethings the disks boot sector is not detected by the computer or is suddenly gone. In this case I have to use bootsect on the drive every time this happens.

When this happened, I had to reformat my computer. The boot problem gets so severe that the filesystem is messed up and I couldn't find a way to fix it (programs or otherwise) so I had to get a program, backup the files I needed then I reformatted. Reformatting should of solved all my problems but it did not.

Please help. I've tried everything. I even looked at how Windows 7 shuts down and it only unloads processes from memory then shuts down once all essential processes has been unloaded. I don't know what's causing it.

Super Dave

WELL if you have another cable handy you can swap it in, and you can try the other IDE channel (if you have one). Other than that, it sounds like you have a failing drive, and I don't know of any way to salvage it, Taylor.


Western Digital made a Green drive in the IDE connection??? I don't see this anywhere on their site or Newegg.


How about trying check disk to check for errors?


Comes in multiple versions (floppy, dos, windows). Could also try butting off of something like Hirens and see what it comes up with.

Good luck either way! Let us know how it goes.


This is quite strange, I would suggest you to first get it checked in a some other computer of your friend and see how it responds. If it does work for in this case and also behaves in the same way as it did at your place. Then it is just the way Dave mentioned that your hard disk is  falling  and there is not a solution that we know to revive it back.


What Raid did you set it to? Raid 0?