I'm currently running Windows XP Pro with SP1. I have recently aquired an HP Photosmart 7260 printer, however I am having problems connecting it. I have 6 USB ports, 4 in the back and 2 in the front. However, the ones in the front have a wire that go through the case, out the back, and plug in to 2 of the 4 at the back. So I only really have 4 in total. My motherboard was replaced recently (within the last month). It's an Asus P4S800-MX.

No matter what drivers I install, or what USB device I try to plugin, or which USB port I plug the device in to, Windows XP Pro will not recognize it. I've tried plugging in some other devices but nothing is detected. When I plugin the printer on another computer, a box pops up saying "New Hardware Detected". That doesn't happen on this computer.

I've checked the BIOS settings, and it seems that the USB ports are enabled. I was told that Service Pack 1 includes USB support. Is this correct? I've installed all the drivers from the motherboard cd and from the Asus website. The USB 2.0 drivers refused to install and said that SP1 had support for USB. Perhaps I should try upgrading to SP2?

Anyone have any ideas? Thanks in advance.

  •  Jordan
  • 50.6% (Neutral)
  • Advanced Member
Even without SP1 XP still has support for USB, it is USB 2.0 that it enables support for. The first thing I would have suggested is trying your BIOS but you have. Have you installed the drivers for the Motherboard chipset? Try gettting the lastest form your Motherboard manufacturers site.
I checked the bios again. The only options I can find are:
USB Legacy Support
USB Fuction
USB 2.0 Function
And they're all set to Enabled.

I updated the drivers from Asus's site.

It still doesn't work.
u installed the chipset drivers from the CD u got with ur mobo?.....I cant tell if you have.
I Installed lots of drivers from the CD and from the Asus website but considering I'm not entirely sure what you mean by "chipset drivers", I can't be certain that they are installed.

hmmmm well it should say in the autorun window something like "install intel i875 chipset drivers" or something like that.

unless u have something from that case it will just say install VIA XXXX chipset drivers".

it should at least.
ON your motherboard there are 2 headers your front panel USB ports plug into these. Do you have installation book for your board If please read it also load your chipse drivers off the CD that came with board . I thinks its time you reformate and do a fresh install of OS than load all drivers from your CD.
Huff N Puff, welcome to the boards.

As a new member you don't quite have the feel of the place yet. Please don't bring old threads back to life. Something that is 2-3 months old has been forgotten or the problem has been taken care of.

You are correct except other people may have same problem and they well read that thread is that not so . I read the threads if there old or new and so do the window shoppers.
Users browsing this topic