I recently reinstalled xp and now the UBS ports wont work. I looked in device manager to see whats going on and this is what i got..

- Intel(r) 82801DB/DBM USB 2.0 Enhanced Host Controller - 24CD
- Intel(r) 82801DB/DBM USB Universal Host Controller -24C2
- Intel(r) 82801DB/DBM USB Universal Host Controller -24C4
- Intel(r) 82801DB/DBM USB Universal Host Controller -24C7

There seems to be nothing wrong with the '2.0 Enhanced Host Controller' saying "The device is working properly". But the 'Universal Host Controllers' all say "No drivers ae installed for this device". :confused:

I tried searching for the drivers on my discs that came with my comp, and the USB is enabled in BIOS. Help please! I'm probably doing something wrong or not looking in the right places. Or a link to were i can download the drivers from. Cheers
SS Joe
Try downloading the latest chipset drivers from your motherboard manufacturers website.
make sure ya update windows as there is a fix for usb2.0 best of luck
Thats the problem! I have the CD with the chipset drivers on it and they still don't work after i install them, and about downloading the windows update...guess what my modem uses! Thats right, a USB connection! So i can't get on the internet ( btw im on a different computer obviously). I'll keep trying though!
Any other suggestions?
If your on NTL seeing as your in the UK you can connect the modem via ethernet if your motherboard comes with a integrated NIC if not just by a NIC card they don't cost a lot best prices you will find are at 

I think my USB 2.0 is fine, but the ones beneath it, that seem to be just normal USB's say thay don't have drivers installed. I havn't got a clue! My comp just doesn't recognise my devices, e.g/ when i plug my camera in and use the software for it, it tells me to plug the device in which it already is. Same goes for my printer.
They worked fine BEFORE i reinstalled XP.
I heard you don't need the drivers for the usb's to work.
Also, i'm gunna buy a new MOBO because the one i have doesn't have an AGP port, so will buying a new MOBO fix this problem?
I tried downloading multiple drivers off the net, and tried searching all of my disks that shipped with the comp, but it just says error: The data is invalid!
yeah a new mobo will fix the problem

Users browsing this topic